Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Risolto] - vlc riproduzione video H264 a quadretti e player alternativo
#1
Salve,
su ubuntu 16.04 ho installato, da software center,  vlc 2.2.2 e funziona benissimo, meno che nella riproduzione di video h.264.
mentre l'audio è ok, il video è sgranato, a scatti e praticamente inguardabile.
ho seguito in giro diverse discussioni, modificando diversi parametri, cache ed altro, ma senza alcun risultato.
Ho visitato il sito Videolan, cercando di scaricare l'ultima versione di vlc.
Dopo aver cercato arrivo alla pagina di download ma compare anche un invito a scaricare vlc da snapstore.
   
Sto sbagliando qualcosa? non vorrei compromettere il mio s.o. per cui chiedo lumi a voi.
Grazie
Ho imparato a pescare; il mio maestro mi ha insegnato bene.  085
Ubuntu16.04 - Ubuntu18.04Gnome - MX-19
Cita messaggio
#2
Ciao
Il parametro Demuxer l'hai già provato?
La vita è come uno specchio:ti sorride se la guardi sorridendo
Un giorno senza rischio è non vissuto..
PCLinuxOS Mate/Xfce/E24 - Forum Manjaro Italia Kde/Mate/Xfce
Cita messaggio
#3
dalla tua immagine postata sembra tu abbia installato tramite snap....... ennesima vittima.
nel terminale:

Citazione:snap list


avrai la lista dei programmi installati tramite snap. se hai vlc, rimuovilo:

Citazione:snap remove nome-esatto


poi se posso permettermi, dimentica il software center ed utilizza solo synaptic.
ovviamente è un mio consiglio, uno che è passato per quelle problematiche tempo fa. per info io ho rimosso sempre da synaptic:
Citazione:snapd


voglio stare "tranquillo" anche se lui in maniera subdola cerca di reinstallarlo quando si aggiorna.

dai anche uno sguardo:
https://wiki.ubuntu-it.org/Multimedia/FormatiLiberi
condividere il piacere di usare:
[Immagine: Cold_Hard_Steel.png]
Cita messaggio
#4
Sulla pagina di download ufficiale per Linux (https://www.videolan.org/vlc/download-ubuntu.html) l'installazione via "snap" è quella proposta, ma non è l'unica. Se scorri la pagina, in fondo (in Inglese...) si indica anche il pacchetto di installazione tradizionale "deb package" con tutti i bugfix disponibile via APT (apt://vlc).
Il mio blog: ZEROZEROCENT.BLOGSPOT.COM
LEGGE DI MURPHY: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
VERSIONE QUANTISTICA DELLA LEGGE DI MURPHY: TUTTO VA MALE CONTEMPORANEAMENTE
Cita messaggio
#5
@mario: non l'ho scaricata; era solo una videata del sito.
@ D-Barto: no non ho provato demuxer;
cosa dovrei provare a cambiare?
   

@Bat: ho provato a scaricare dopo aver eliminato la versione 2.2.2 da terminale

Codice:
sudo apt remove --purge vlc
scorrendo la pagina del sito fino a cliccare sulla riga vlc for ubuntu, ma mi riporta alla schermata che ho allegato prima, dove mi suggerisce anche di installare con snap via terminale
Codice:
sudo snap install vlc

allora ho provato a installarlo con comando classico
Codice:
sudo apt install vlc

ma la versione appena installata, (3.0) presenta una interfaccia con caratteri piccolissimi che a fatica riesco a leggere.
Di conseguenza ho eliminato tutto e sono ritornato alla versione 2.2.2, installandola da software center, ritrovandomi con le problematiche accennate all'inizio del post
Ho imparato a pescare; il mio maestro mi ha insegnato bene.  085
Ubuntu16.04 - Ubuntu18.04Gnome - MX-19
Cita messaggio
#6
Nella schermata dove sei non selezionare quello ma vai proprio su demuxer e ci clicchi sopra ti apparira un menù dove c è scritto automatico lo apri e scegli Demuxer video h264     poi salvi e riprovi a vedere.
Ps. è una possibilità.
La vita è come uno specchio:ti sorride se la guardi sorridendo
Un giorno senza rischio è non vissuto..
PCLinuxOS Mate/Xfce/E24 - Forum Manjaro Italia Kde/Mate/Xfce
Cita messaggio
#7
ho provato, ma cliccando su demuxer e poi scegliendo demuxer video h264, salvando ovviamente all'uscita, vlc non apre addirittura la riproduzione del video.
Farò delle prove scegliendo ad una ad una tutte le opzioni presenti.
a dopo
Ho imparato a pescare; il mio maestro mi ha insegnato bene.  085
Ubuntu16.04 - Ubuntu18.04Gnome - MX-19
Cita messaggio
#8
Sei sicuro che sia h264?
Di che video si tratta "se si puo sapere" naturalmente.
La vita è come uno specchio:ti sorride se la guardi sorridendo
Un giorno senza rischio è non vissuto..
PCLinuxOS Mate/Xfce/E24 - Forum Manjaro Italia Kde/Mate/Xfce
Cita messaggio
#9
Domanda sciocca, ma non si sa mai...hai installato tutti i codec?

Codice:
sudo apt-get install -y gstreamer0.10-fluendo-mp3 gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly libavcodec5. libavdevice5. libavformat5. libavutil5. libpostproc5. libswscale.$
It's Never Too Fast

[Immagine: iZXqUY2.png]
Cita messaggio
#10
Non sapendo se ci sono oppure no, ho dato il comando da terminale e la risposta è:

Codice:
apanta@apanta-desktop:~$ sudo apt-get install -y gstreamer0.10-fluendo-mp3 gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly libavcodec5. libavdevice5. libavformat5. libavutil5. libpostproc5. libswscale.$
[sudo] password di apanta:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze     
Lettura informazioni sullo stato... Fatto
Il pacchetto gstreamer0.10-plugins-ugly non ha versioni disponibili, ma è nominato da un altro
pacchetto. Questo potrebbe indicare che il pacchetto è mancante, obsoleto
oppure è disponibile solo all'interno di un'altra sorgente

Il pacchetto gstreamer0.10-plugins-bad non ha versioni disponibili, ma è nominato da un altro
pacchetto. Questo potrebbe indicare che il pacchetto è mancante, obsoleto
oppure è disponibile solo all'interno di un'altra sorgente
Tuttavia questi pacchetti lo sostituiscono:
  gstreamer0.10-plugins-good:i386 gstreamer0.10-plugins-base:i386 gstreamer0.10-plugins-good
  gstreamer0.10-plugins-base

E: Impossibile trovare il pacchetto gstreamer0.10-fluendo-mp3
E: Impossibile trovare alcun pacchetto tramite il glob "gstreamer0.10-fluendo-mp3"
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "gstreamer0.10-fluendo-mp3"
E: Il pacchetto "gstreamer0.10-plugins-bad" non ha candidati da installare
E: Impossibile trovare il pacchetto gstreamer0.10-plugins-bad-multiverse
E: Impossibile trovare alcun pacchetto tramite il glob "gstreamer0.10-plugins-bad-multiverse"
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "gstreamer0.10-plugins-bad-multiverse"
E: Il pacchetto "gstreamer0.10-plugins-ugly" non ha candidati da installare
E: Impossibile trovare il pacchetto libavcodec5.
E: Impossibile trovare alcun pacchetto tramite il glob "libavcodec5."
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "libavcodec5."
E: Impossibile trovare il pacchetto libavdevice5.
E: Impossibile trovare alcun pacchetto tramite il glob "libavdevice5."
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "libavdevice5."
E: Impossibile trovare il pacchetto libavformat5.
E: Impossibile trovare alcun pacchetto tramite il glob "libavformat5."
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "libavformat5."
E: Impossibile trovare il pacchetto libavutil5.
E: Impossibile trovare alcun pacchetto tramite il glob "libavutil5."
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "libavutil5."
E: Impossibile trovare il pacchetto libpostproc5.
E: Impossibile trovare alcun pacchetto tramite il glob "libpostproc5."
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "libpostproc5."
E: Impossibile trovare il pacchetto libswscale.$
E: Impossibile trovare alcun pacchetto tramite il glob "libswscale.$"
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "libswscale.$"
apanta@apanta-desktop:~$
per cui  mi trovo ancora bloccato
edit: per i moderatori: il testo all'interno dello spoiler è allineato al centro,; sarebbe opportuno che fosse allineato a sinistra.
Ho imparato a pescare; il mio maestro mi ha insegnato bene.  085
Ubuntu16.04 - Ubuntu18.04Gnome - MX-19
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)